summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:11:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:11:53 +0000
commit3b2454db9951fcab14720c80591627ff3d23a3fc (patch)
treef45b6407239285630662028c487354fbe0d3c9b2 /kde-base
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-3b2454db9951fcab14720c80591627ff3d23a3fc.tar.gz
gentoo-2-3b2454db9951fcab14720c80591627ff3d23a3fc.tar.bz2
gentoo-2-3b2454db9951fcab14720c80591627ff3d23a3fc.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/noatun-plugins/ChangeLog8
-rw-r--r--kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.53
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.5.ebuild32
3 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index 6990322c57a8..8b31e7f86ce3 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.52 2006/09/26 22:08:27 deathwing00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.53 2006/10/03 13:11:53 flameeyes Exp $
+
+*noatun-plugins-3.5.5 (03 Oct 2006)
+
+ 03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +noatun-plugins-3.5.5.ebuild:
+ Bump to 3.5.5 (pre-release).
26 Sep 2006; Ioannis Aslanidis <deathwing00@gentoo.org>
noatun-plugins-3.5.2.ebuild, noatun-plugins-3.5.3.ebuild,
diff --git a/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.5 b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.5
new file mode 100644
index 000000000000..16b8b41f83cd
--- /dev/null
+++ b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.5
@@ -0,0 +1,3 @@
+MD5 71c0a690abf8ad0f43135fa887d0b40c kdeaddons-3.5.5.tar.bz2 1663195
+RMD160 4a8e43e3268dc687de049482be57e1372a6abea3 kdeaddons-3.5.5.tar.bz2 1663195
+SHA256 1db58293a8b967d254a39c9bdb0c5dfb3759a7d067280dd3d637e2423beb632c kdeaddons-3.5.5.tar.bz2 1663195
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.5.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.5.ebuild
new file mode 100644
index 000000000000..20c9d961e1ec
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.5.ebuild,v 1.1 2006/10/03 13:11:53 flameeyes Exp $
+KMNAME=kdeaddons
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit db-use kde-meta
+
+DESCRIPTION="Various plugins for Noatun."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="arts sdl berkdb"
+
+DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/noatun)
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( =sys-libs/db-4* )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf="$(use_with sdl)"
+
+ if use berkdb; then
+ dblib="$(db_libname)"
+ myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
+ --with-extra-includes=${ROOT}$(db_includedir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde-meta_src_compile
+}