summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-13 16:17:04 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-13 16:17:04 +0000
commit1a9ee316eadfd0f835384063ba1b625434a4c3c3 (patch)
tree0dc1aff826485bd0bd7c3249d2cab4a3f4bc1163 /kde-base
parentFix changelog (diff)
downloadgentoo-2-1a9ee316eadfd0f835384063ba1b625434a4c3c3.tar.gz
gentoo-2-1a9ee316eadfd0f835384063ba1b625434a4c3c3.tar.bz2
gentoo-2-1a9ee316eadfd0f835384063ba1b625434a4c3c3.zip
Dont install kdepim files if they are included in the tarballs, bug 366353
(Portage version: 2.1.10.5/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kde-l10n/ChangeLog11
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.6.3-r2.ebuild93
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.6.4-r1.ebuild93
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.6.5-r1.ebuild93
4 files changed, 289 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 3d942c32dbc4..12e1965d6d6f 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.97 2011/07/09 15:13:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.98 2011/07/13 16:17:04 dilfridge Exp $
+
+*kde-l10n-4.6.5-r1 (13 Jul 2011)
+*kde-l10n-4.6.4-r1 (13 Jul 2011)
+*kde-l10n-4.6.3-r2 (13 Jul 2011)
+
+ 13 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kde-l10n-4.6.3-r2.ebuild, +kde-l10n-4.6.4-r1.ebuild,
+ +kde-l10n-4.6.5-r1.ebuild:
+ Dont install kdepim files if they are included in the tarballs, bug 366353
*kde-l10n-4.6.5 (09 Jul 2011)
diff --git a/kde-base/kde-l10n/kde-l10n-4.6.3-r2.ebuild b/kde-base/kde-l10n/kde-l10n-4.6.3-r2.ebuild
new file mode 100644
index 000000000000..1b107a5a6dda
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.6.3-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.6.3-r2.ebuild,v 1.1 2011/07/13 16:17:04 dilfridge Exp $
+
+EAPI="3"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="!<kde-misc/konq-plugins-4.6"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.bz2::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg ca ca@valencia cs da de el en_GB es et eu fi fr ga gl gu he hi
+hr hu ia id is it ja kk km kn ko lt lv mai nb nds nl nn pa pl pt pt_BR ro ru sk
+sl sr sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ # Upstream added kdepim-runtime translations by mistake and does not want to
+ # make a new tarball, bug 366353
+
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim-runtime):# no kdepim-runtime:g' {} +
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim):# no kdepim:g' {} +
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}
diff --git a/kde-base/kde-l10n/kde-l10n-4.6.4-r1.ebuild b/kde-base/kde-l10n/kde-l10n-4.6.4-r1.ebuild
new file mode 100644
index 000000000000..6423a1001c3d
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.6.4-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.6.4-r1.ebuild,v 1.1 2011/07/13 16:17:04 dilfridge Exp $
+
+EAPI="3"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="!<kde-misc/konq-plugins-4.6"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.bz2::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg ca ca@valencia cs da de el en_GB es et eu fi fr ga gl gu he hi
+hr hu ia id is it ja kk km kn ko lt lv mai nb nds nl nn pa pl pt pt_BR ro ru sk
+sl sr sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ # Upstream added kdepim-runtime translations by mistake and does not want to
+ # make a new tarball, bug 366353
+
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim-runtime):# no kdepim-runtime:g' {} +
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim):# no kdepim:g' {} +
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}
diff --git a/kde-base/kde-l10n/kde-l10n-4.6.5-r1.ebuild b/kde-base/kde-l10n/kde-l10n-4.6.5-r1.ebuild
new file mode 100644
index 000000000000..e59cf25b6136
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.6.5-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.6.5-r1.ebuild,v 1.1 2011/07/13 16:17:04 dilfridge Exp $
+
+EAPI="3"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="!<kde-misc/konq-plugins-4.6"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.bz2::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg ca ca@valencia cs da de el en_GB es et eu fi fr ga gl gu he hi
+hr hu ia id is it ja kk km kn ko lt lv mai nb nds nl nn pa pl pt pt_BR ro ru sk
+sl sr sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ # Upstream added kdepim-runtime translations by mistake and does not want to
+ # make a new tarball, bug 366353
+
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim-runtime):# no kdepim-runtime:g' {} +
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:add_subdirectory(kdepim):# no kdepim:g' {} +
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}