summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-15 13:53:34 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-15 13:53:34 +0000
commit19b4e3e2fa2f0fed8acacd9fc2860909517454e4 (patch)
tree8fac938ad7c0ac3a31887e0a4f76bb899f85133e /kde-base
parentStable for sh, wrt bug #461278 (diff)
downloadgentoo-2-19b4e3e2fa2f0fed8acacd9fc2860909517454e4.tar.gz
gentoo-2-19b4e3e2fa2f0fed8acacd9fc2860909517454e4.tar.bz2
gentoo-2-19b4e3e2fa2f0fed8acacd9fc2860909517454e4.zip
Backport patch from upstream to fix build with USE="-fits indi".
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kstars/ChangeLog6
-rw-r--r--kde-base/kstars/files/kstars-4.10.1-build.patch137
-rw-r--r--kde-base/kstars/kstars-4.10.1.ebuild4
3 files changed, 145 insertions, 2 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 78916fe2e722..7ae4e5da2fe6 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.258 2013/03/06 13:41:58 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.259 2013/03/15 13:53:34 kensington Exp $
+
+ 15 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/kstars-4.10.1-build.patch, kstars-4.10.1.ebuild:
+ Backport patch from upstream to fix build with USE="-fits indi".
*kstars-4.10.1 (06 Mar 2013)
diff --git a/kde-base/kstars/files/kstars-4.10.1-build.patch b/kde-base/kstars/files/kstars-4.10.1-build.patch
new file mode 100644
index 000000000000..b44db2528eaf
--- /dev/null
+++ b/kde-base/kstars/files/kstars-4.10.1-build.patch
@@ -0,0 +1,137 @@
+From d9dfd9a2b3e337cf92a89e944ca14f2cf8a328d7 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Sat, 16 Mar 2013 00:37:27 +1100
+Subject: [PATCH] Fix building issues with cfitsio disabled.
+
+BUG: 316464
+REVIEW: 109477
+---
+ kstars/CMakeLists.txt | 6 ++++--
+ kstars/indi/indiccd.cpp | 9 +++++++++
+ kstars/kstarsactions.cpp | 8 +++++---
+ 3 files changed, 18 insertions(+), 5 deletions(-)
+
+diff --git a/kstars/CMakeLists.txt b/kstars/CMakeLists.txt
+index 52d35f2..2d00264 100644
+--- a/kstars/CMakeLists.txt
++++ b/kstars/CMakeLists.txt
+@@ -53,6 +53,7 @@ if (INDI_FOUND)
+ indi/telescopewizard.ui
+ )
+
++if (CFITSIO_FOUND)
+ set(ekosui_SRCS
+ ekos/opsekos.ui
+ ekos/ekosmanager.ui
+@@ -78,7 +79,8 @@ if (INDI_FOUND)
+ ekos/guide/scroll_graph.cpp
+ ekos/guide/vect.cpp
+ )
+-
++endif(CFITSIO_FOUND)
++
+ include_directories(${INDI_INCLUDE_DIR})
+ endif(INDI_FOUND)
+
+@@ -443,7 +445,7 @@ kde4_add_kcfg_files(kstars_SRCS ${kstars_KCFG_SRCS})
+ #kde4_add_dcop_skels(kstars_SRCS kstarsinterface.h simclockinterface.h )
+
+ kde4_add_ui_files(kstars_SRCS
+- ${indiui_SRCS} ${ekosui_SRCS} ${fitsui_SRCS} ${xplanetui_SRCS} ${kstars_optionsui_SRCS} ${kstars_dialogsui_SRCS}
++ ${indiui_SRCS} ${ui_SRCS} ${fitsui_SRCS} ${ekosui_SRCS} ${xplanetui_SRCS} ${kstars_optionsui_SRCS} ${kstars_dialogsui_SRCS}
+ ${printingui_SRCS}
+ thumbnailpicker.ui thumbnaileditor.ui oal/observeradd.ui oal/equipmentwriter.ui oal/execute.ui skycomponents/notifyupdatesui.ui
+ )
+diff --git a/kstars/indi/indiccd.cpp b/kstars/indi/indiccd.cpp
+index 67311af..a578a1a 100644
+--- a/kstars/indi/indiccd.cpp
++++ b/kstars/indi/indiccd.cpp
+@@ -7,6 +7,8 @@
+ version 2 of the License, or (at your option) any later version.
+ */
+
++#include <config-kstars.h>
++
+ #include <string.h>
+
+ #include <KMessageBox>
+@@ -15,8 +17,11 @@
+
+ #include <basedevice.h>
+
++#ifdef HAVE_CFITSIO_H
+ #include "fitsviewer/fitsviewer.h"
+ #include "fitsviewer/fitscommon.h"
++#endif
++
+ #include "clientmanager.h"
+ #include "streamwg.h"
+ #include "indiccd.h"
+@@ -477,7 +482,9 @@ CCD::CCD(GDInterface *iPtr) : DeviceDecorator(iPtr)
+
+ CCD::~CCD()
+ {
++#ifdef HAVE_CFITSIO_H
+ delete (fv);
++#endif
+ delete (streamWindow);
+ delete (primaryChip);
+ delete (guideChip);
+@@ -755,6 +762,7 @@ void CCD::processBLOB(IBLOB* bp)
+
+ void CCD::addFITSKeywords(QString filename)
+ {
++#ifdef HAVE_CFITSIO_H
+ int status=0;
+
+ if (filter.isEmpty() == false)
+@@ -780,6 +788,7 @@ void CCD::addFITSKeywords(QString filename)
+
+ filter = "";
+ }
++#endif
+ }
+
+ void CCD::FITSViewerDestroyed()
+diff --git a/kstars/kstarsactions.cpp b/kstars/kstarsactions.cpp
+index 0d7eb37..1e76bc4 100644
+--- a/kstars/kstarsactions.cpp
++++ b/kstars/kstarsactions.cpp
+@@ -86,10 +86,8 @@
+ #include <config-kstars.h>
+
+ #ifdef HAVE_INDI_H
+-#include "ekos/ekosmanager.h"
+ #include "indi/telescopewizardprocess.h"
+ #include "indi/opsindi.h"
+-#include "ekos/opsekos.h"
+ #include "indi/drivermanager.h"
+ #include "indi/guimanager.h"
+ #endif
+@@ -104,7 +102,8 @@
+ #ifdef HAVE_CFITSIO_H
+ #include "fitsviewer/fitsviewer.h"
+ #ifdef HAVE_INDI_H
+-//#include "ekos/ekos.h"
++#include "ekos/ekosmanager.h"
++#include "ekos/opsekos.h"
+ #endif
+ #endif
+
+@@ -444,10 +443,13 @@ void KStars::slotViewOps() {
+ opsindi = new OpsINDI (this);
+ dialog->addPage(opsindi, i18n("INDI"), "kstars");
+
++ #ifdef HAVE_CFITSIO_H
+ opsekos = new OpsEkos(this);
+ dialog->addPage(opsekos, i18n("Ekos"), "kstars");
+ #endif
+
++ #endif
++
+ #ifdef HAVE_XPLANET
+ opsxplanet = new OpsXplanet( this );
+ dialog->addPage(opsxplanet, i18n("Xplanet"), "kstars_xplanet");
+--
+1.8.1.5
+
diff --git a/kde-base/kstars/kstars-4.10.1.ebuild b/kde-base/kstars/kstars-4.10.1.ebuild
index b8a5e216a553..88b0e465962f 100644
--- a/kde-base/kstars/kstars-4.10.1.ebuild
+++ b/kde-base/kstars/kstars-4.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.10.1.ebuild,v 1.1 2013/03/06 13:41:58 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.10.1.ebuild,v 1.2 2013/03/15 13:53:34 kensington Exp $
EAPI=5
@@ -19,6 +19,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
src_configure() {
# Bug 308903
use ppc64 && append-flags -mminimal-toc