summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-09 12:42:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-09 12:42:47 +0000
commit0de718658839c469010251bfa72fd6d0360a5aa3 (patch)
tree64ad8a8c9df6be7f01d4c5aa560b4dcbfe4bcaad /kde-base
parentMigrate to EAPI 2. (diff)
downloadgentoo-2-0de718658839c469010251bfa72fd6d0360a5aa3.tar.gz
gentoo-2-0de718658839c469010251bfa72fd6d0360a5aa3.tar.bz2
gentoo-2-0de718658839c469010251bfa72fd6d0360a5aa3.zip
Make doc translations optionaly installable.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kde-l10n/ChangeLog8
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.2.3-r1.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index d1f44cec0871..a7700874bd87 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.26 2009/05/06 23:11:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.27 2009/05/09 12:42:47 scarabeus Exp $
+
+*kde-l10n-4.2.3-r1 (09 May 2009)
+
+ 09 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +kde-l10n-4.2.3-r1.ebuild:
+ Make doc translations optionaly installable.
*kde-l10n-4.2.3 (06 May 2009)
diff --git a/kde-base/kde-l10n/kde-l10n-4.2.3-r1.ebuild b/kde-base/kde-l10n/kde-l10n-4.2.3-r1.ebuild
new file mode 100644
index 000000000000..7d466b0af095
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.2.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.2.3-r1.ebuild,v 1.1 2009/05/09 12:42:47 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+MY_LANGS="ar bg bn_IN ca cs csb da de el en_GB es et eu fi fr ga gl gu he hi hu
+ is it ja kk km kn ko ku lt lv mai mk ml mr nb nds nl nn pa pl pt pt_BR
+ ro ru sk sl sr sv tg th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build doc docs)"
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}