summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/thumbnailers
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/thumbnailers')
-rw-r--r--kde-base/thumbnailers/ChangeLog7
-rw-r--r--kde-base/thumbnailers/thumbnailers-4.6.5.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/thumbnailers/ChangeLog b/kde-base/thumbnailers/ChangeLog
index 9aecd4850160..8e6de527855a 100644
--- a/kde-base/thumbnailers/ChangeLog
+++ b/kde-base/thumbnailers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/thumbnailers
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/thumbnailers/ChangeLog,v 1.58 2011/07/06 20:05:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/thumbnailers/ChangeLog,v 1.59 2011/07/09 15:14:02 alexxy Exp $
+
+*thumbnailers-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +thumbnailers-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-thumbnailers-4.6.2.ebuild:
diff --git a/kde-base/thumbnailers/thumbnailers-4.6.5.ebuild b/kde-base/thumbnailers/thumbnailers-4.6.5.ebuild
new file mode 100644
index 000000000000..32aca9e62dd0
--- /dev/null
+++ b/kde-base/thumbnailers/thumbnailers-4.6.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/thumbnailers/thumbnailers-4.6.5.ebuild,v 1.1 2011/07/09 15:14:02 alexxy Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdegraphics-thumbnailers"
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdegraphics"
+ kde_eclass="kde4-meta"
+fi
+
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE 4 thumbnail generators for PDF/PS files"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+KMEXTRACTONLY="
+ libs/mobipocket
+"
+
+DEPEND="
+ $(add_kdebase_dep libkdcraw)
+ $(add_kdebase_dep libkexiv2)
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kdegraphics-strigi-analyzer '<4.2.91'
+
+if [[ ${PV} != *9999 ]]; then
+src_install() {
+ kde4-meta_src_install
+
+ # why, oh why?!
+ rm "${ED}/usr/share/apps/cmake/modules/FindKSane.cmake" || die
+}
+fi