summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:25:21 +0000
committerBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:25:21 +0000
commit9b1a875ba16fb07263e89840b539b278c5ead3e1 (patch)
tree102e0ccbf874519f1f95ed3b2b19762c2db188e3 /kde-base/systemsettings
parentMarking libao-0.8.8 ppc64 for bug 207682 (diff)
downloadgentoo-2-9b1a875ba16fb07263e89840b539b278c5ead3e1.tar.gz
gentoo-2-9b1a875ba16fb07263e89840b539b278c5ead3e1.tar.bz2
gentoo-2-9b1a875ba16fb07263e89840b539b278c5ead3e1.zip
Fix compilation with USE=-opengl. For bug #206517. Fix a typo.
(Portage version: 2.1.4)
Diffstat (limited to 'kde-base/systemsettings')
-rw-r--r--kde-base/systemsettings/ChangeLog6
-rw-r--r--kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch21
-rw-r--r--kde-base/systemsettings/systemsettings-4.0.0.ebuild6
3 files changed, 30 insertions, 3 deletions
diff --git a/kde-base/systemsettings/ChangeLog b/kde-base/systemsettings/ChangeLog
index 08aec9bc4252..abe38f6d6e29 100644
--- a/kde-base/systemsettings/ChangeLog
+++ b/kde-base/systemsettings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/systemsettings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.1 2008/01/18 02:06:35 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.2 2008/01/27 15:25:21 zlin Exp $
+
+ 27 Jan 2008; Bo Ørsted Andresen <zlin@gentoo.org>
+ +files/systemsettings-4.0.0-opengl.patch, systemsettings-4.0.0.ebuild:
+ Fix compilation with USE=-opengl. For bug #206517. Fix a typo.
*systemsettings-4.0.0 (18 Jan 2008)
diff --git a/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch b/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch
new file mode 100644
index 000000000000..f3e6a966b4ff
--- /dev/null
+++ b/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch
@@ -0,0 +1,21 @@
+--- workspace/CMakeLists.txt (revision 767202)
++++ workspace/CMakeLists.txt (working copy)
+@@ -16,8 +16,6 @@
+ include (MacroLibrary)
+ include (KDE4Defaults)
+
+-macro_optional_find_package(OpenGL)
+-
+ include(ConfigureChecks.cmake)
+ configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
+--- workspace/kcontrol/screensaver/CMakeLists.txt
++++ workspace/kcontrol/screensaver/CMakeLists.txt
+@@ -1,5 +1,7 @@
+
++if(WITH_OpenGL)
+ check_library_exists(GL glXChooseVisual "" HAVE_GLXCHOOSEVISUAL)
++endif(WITH_OpenGL)
+ configure_file (config-screensaver.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-screensaver.h )
+
+ add_definitions (-DQT3_SUPPORT)
diff --git a/kde-base/systemsettings/systemsettings-4.0.0.ebuild b/kde-base/systemsettings/systemsettings-4.0.0.ebuild
index 61438a026e55..693bad5116d5 100644
--- a/kde-base/systemsettings/systemsettings-4.0.0.ebuild
+++ b/kde-base/systemsettings/systemsettings-4.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.0.0.ebuild,v 1.1 2008/01/18 02:06:35 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.0.0.ebuild,v 1.2 2008/01/27 15:25:21 zlin Exp $
EAPI="1"
@@ -44,6 +44,8 @@ KMEXTRACTONLY="
libs/
plasma/"
+PATCHES="${FILESDIR}/${P}-opengl.patch"
+
# FIXME: is have_openglxvisual found without screensaver
src_compile() {
# Old keyboard-detection code is unmaintained,
@@ -51,7 +53,7 @@ src_compile() {
mycmakeargs="${mycmakeargs}
-DUSE_XKLAVIER=ON -DWITH_LibXKlavier=ON
-DWITH_GLIB2=ON -DWITH_GObject=ON
- $(cmake-utils_usr_with ieee1394 RAW1394)
+ $(cmake-utils_use_with ieee1394 RAW1394)
$(cmake-utils_use_with opengl OpenGL)
$(cmake-utils_use_with ssl OpenSSL)
$(cmake-utils_use_with usb USB)