summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit9105207da0f7d5c2674846f47a99baf903903d3b (patch)
treed50899ea0ccfdaee04b35bfc24e0bc89b3d4c12a /kde-base/superkaramba
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadgentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.gz
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.bz2
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.zip
[kde-base] KDE SC 4.7.2
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.7.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index d97ede586b74..f435fe648d8f 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.175 2011/09/07 20:13:39 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.176 2011/10/06 18:11:00 alexxy Exp $
+
+*superkaramba-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +superkaramba-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*superkaramba-4.7.1 (07 Sep 2011)
diff --git a/kde-base/superkaramba/superkaramba-4.7.2.ebuild b/kde-base/superkaramba/superkaramba-4.7.2.ebuild
new file mode 100644
index 000000000000..201298712a63
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.7.2.ebuild,v 1.1 2011/10/06 18:11:00 alexxy Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeutils"
+ kde_eclass="kde4-meta"
+fi
+inherit python ${kde_eclass}
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ ${kde_eclass}_pkg_setup
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ ${kde_eclass}_src_configure
+}