summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:05:51 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:05:51 +0000
commit55cbe24aa4de0bc87801e2736bc064866c045328 (patch)
tree4390a82ed0e929662f1f7e906561d7619ebe4314 /kde-base/superkaramba
parentVersion bump KDE SC 4.5.1 (diff)
downloadgentoo-2-55cbe24aa4de0bc87801e2736bc064866c045328.tar.gz
gentoo-2-55cbe24aa4de0bc87801e2736bc064866c045328.tar.bz2
gentoo-2-55cbe24aa4de0bc87801e2736bc064866c045328.zip
Version bump KDE SC 4.5.1
(Portage version: 2.2_rc75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog8
-rw-r--r--kde-base/superkaramba/superkaramba-4.5.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index aace6405e907..a5bef12700dc 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.151 2010/08/09 17:34:40 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.152 2010/09/06 02:05:51 tampakrap Exp $
+
+*superkaramba-4.5.1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +superkaramba-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
superkaramba-4.4.5.ebuild:
diff --git a/kde-base/superkaramba/superkaramba-4.5.1.ebuild b/kde-base/superkaramba/superkaramba-4.5.1.ebuild
new file mode 100644
index 000000000000..035204bf071c
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.5.1.ebuild,v 1.1 2010/09/06 02:05:51 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdeutils"
+PYTHON_DEPEND="python? 2"
+inherit python kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS=""
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-meta_src_configure
+}