summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:55 +0000
commitf0035022e119994c707077c0db8f82c681603517 (patch)
tree20c465ad77c4326d4e9f6babfd017fc86b49fed6 /kde-base/step
parent[kde-base/kcachegrind] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-f0035022e119994c707077c0db8f82c681603517.tar.gz
gentoo-2-f0035022e119994c707077c0db8f82c681603517.tar.bz2
gentoo-2-f0035022e119994c707077c0db8f82c681603517.zip
[kde-base/step] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.4.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 0c924210a9c9..fe9ca91fb619 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.42 2010/01/25 17:40:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.43 2010/02/09 00:22:55 alexxy Exp $
+
+*step-4.4.0 (09 Feb 2010)
+
+ 09 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +step-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*step-4.3.5 (25 Jan 2010)
diff --git a/kde-base/step/step-4.4.0.ebuild b/kde-base/step/step-4.4.0.ebuild
new file mode 100644
index 000000000000..4ff4d7e504ac
--- /dev/null
+++ b/kde-base/step/step-4.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.4.0.ebuild,v 1.1 2010/02/09 00:22:55 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+
+ kde4-meta_src_configure
+}