summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commitb0b482a63f92c732c21a7a05f6e91ed9d13d91e6 (patch)
tree5874d7078782459c535f58fd83e3acaff5ea7f72 /kde-base/solid
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadgentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.gz
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.bz2
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.zip
[kde-base] Add KDE SC 4.5.4
(Portage version: 2.2.0_alpha6_p10/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.5.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index 77ca3e8b94a9..19c79a3a2f7b 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.89 2010/11/03 16:30:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.90 2010/12/02 21:14:27 alexxy Exp $
+
+*solid-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*solid-4.5.3 (03 Nov 2010)
diff --git a/kde-base/solid/solid-4.5.4.ebuild b/kde-base/solid/solid-4.5.4.ebuild
new file mode 100644
index 000000000000..151c66e10c5f
--- /dev/null
+++ b/kde-base/solid/solid-4.5.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.5.4.ebuild,v 1.1 2010/12/02 21:14:27 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug +hal networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+ hal? ( sys-apps/hal )
+"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.69-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}