summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:44:21 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:44:21 +0000
commit778ca7eef312875e337cc7bddbbb3d574c0f3f16 (patch)
treed7d452d9803db7af11f764f4c650f483494f0815 /kde-base/solid
parentAdd KDE 4.2.2 (diff)
downloadgentoo-2-778ca7eef312875e337cc7bddbbb3d574c0f3f16.tar.gz
gentoo-2-778ca7eef312875e337cc7bddbbb3d574c0f3f16.tar.bz2
gentoo-2-778ca7eef312875e337cc7bddbbb3d574c0f3f16.zip
Add KDE 4.2.2
(Portage version: 2.2_rc29/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.2.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index 47be126d0292..862729e7f643 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.25 2009/04/11 16:05:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.26 2009/04/12 06:44:21 alexxy Exp $
+
+*solid-4.2.2 (11 Apr 2009)
+
+ 11 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.2.2.ebuild:
+ Add KDE 4.2.2
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> solid-4.2.1.ebuild:
Add ~alpha/~ia64 wrt #260777
diff --git a/kde-base/solid/solid-4.2.2.ebuild b/kde-base/solid/solid-4.2.2.ebuild
new file mode 100644
index 000000000000..6058adf26aaf
--- /dev/null
+++ b/kde-base/solid/solid-4.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.2.2.ebuild,v 1.1 2009/04/12 06:44:21 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-4.2.0-backport-solid-bluetooth.patch.tar.bz2"
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug networkmanager"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ >=sys-apps/hal-0.5.9
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=( "${DISTDIR}/${PN}-4.2.0-backport-solid-bluetooth.patch.tar.bz2" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ elog "If you want to be notified about new plugged devices by a popup,"
+ elog "install kde-base/soliduiserver"
+
+ kde4-meta_pkg_postinst
+}