summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commit588eb8e56926b65029e4de63aa398e51ed8cc9b8 (patch)
tree356a5e95843b62ad54fc9c77facba6ff67c4db94 /kde-base/solid
parentx86 stable, bug 323729 (diff)
downloadgentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.gz
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.bz2
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.zip
[kde-base] Bump KDE SC 4.4.5 =)
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.4.5.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index fe864ec4959a..bd854884f80c 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.75 2010/06/28 03:58:04 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.76 2010/06/30 15:37:08 alexxy Exp $
+
+*solid-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.4.5.ebuild:
+ Version bump
28 Jun 2010; Christian Faulhammer <fauli@gentoo.org> solid-4.4.4.ebuild:
x86 stable, bug 322791
diff --git a/kde-base/solid/solid-4.4.5.ebuild b/kde-base/solid/solid-4.4.5.ebuild
new file mode 100644
index 000000000000..7b43bc89763b
--- /dev/null
+++ b/kde-base/solid/solid-4.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.4.5.ebuild,v 1.1 2010/06/30 15:37:08 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}