summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 22:55:49 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 22:55:49 +0000
commit055df0eb9c3123913503558f5c47d453fbfaeb74 (patch)
tree0497b154db2d145687c2e7c27ef1146bbad82a43 /kde-base/solid
parentBump KDE 4.2.1 (diff)
downloadgentoo-2-055df0eb9c3123913503558f5c47d453fbfaeb74.tar.gz
gentoo-2-055df0eb9c3123913503558f5c47d453fbfaeb74.tar.bz2
gentoo-2-055df0eb9c3123913503558f5c47d453fbfaeb74.zip
Bump KDE 4.2.1
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.2.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index c565351fe102..dc71ab04f246 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.20 2009/02/17 14:33:55 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.21 2009/03/04 22:55:49 alexxy Exp $
+
+*solid-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.2.1.ebuild:
+ Bump KDE 4.2.1
17 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> -solid-4.1.4.ebuild:
Drop KDE 4.1.4
diff --git a/kde-base/solid/solid-4.2.1.ebuild b/kde-base/solid/solid-4.2.1.ebuild
new file mode 100644
index 000000000000..340a87ad3ec6
--- /dev/null
+++ b/kde-base/solid/solid-4.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.2.1.ebuild,v 1.1 2009/03/04 22:55:49 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-4.2.0-backport-solid-bluetooth.patch.tar.bz2"
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug networkmanager"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ >=sys-apps/hal-0.5.9
+ bluetooth? (
+ || (
+ net-wireless/bluez
+ net-wireless/bluez-libs
+ )
+ )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ elog "If you want to be notified about new plugged devices by a popup,"
+ elog "install kde-base/soliduiserver"
+
+ kde4-meta_pkg_postinst
+}