summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/smokeqt
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.8.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index de60c675cb9c..1ea847edb108 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.13 2012/01/17 13:29:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.14 2012/01/25 18:16:46 johu Exp $
+
+*smokeqt-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +smokeqt-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -smokeqt-4.7.3.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/smokeqt/smokeqt-4.8.0.ebuild b/kde-base/smokeqt/smokeqt-4.8.0.ebuild
new file mode 100644
index 000000000000..e1e4080fcd7f
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.8.0.ebuild,v 1.1 2012/01/25 18:16:46 johu Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-test:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( x11-libs/qt-webkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}