summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
commit053fab4599b7a153575d6540f06f69fecd0d2740 (patch)
tree4f7d23e33c53b4249e734fa22c9151eae906afd0 /kde-base/smokeqt
parentFixed and marked for ~x64-macos, bug #479554 (diff)
downloadgentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.gz
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.bz2
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.zip
Version bump KDE SC 4.11.0
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog8
-rw-r--r--kde-base/smokeqt/smokeqt-4.11.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 018ae8823c46..e5a6284a52b1 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.88 2013/08/05 03:04:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.89 2013/08/14 20:23:25 dilfridge Exp $
+
+*smokeqt-4.11.0 (14 Aug 2013)
+
+ 14 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +smokeqt-4.11.0.ebuild:
+ Version bump KDE SC 4.11.0
05 Aug 2013; Patrick Lauer <patrick@gentoo.org> smokeqt-4.10.5.ebuild:
Improving Qt deps for qtgui/designer split
diff --git a/kde-base/smokeqt/smokeqt-4.11.0.ebuild b/kde-base/smokeqt/smokeqt-4.11.0.ebuild
new file mode 100644
index 000000000000..17f75f537f29
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.11.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.11.0.ebuild,v 1.1 2013/08/14 20:23:25 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Smoke"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla:= )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}