summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/smokekde/smokekde-4.8.0.ebuild
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/smokekde/smokekde-4.8.0.ebuild')
-rw-r--r--kde-base/smokekde/smokekde-4.8.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/smokekde/smokekde-4.8.0.ebuild b/kde-base/smokekde/smokekde-4.8.0.ebuild
new file mode 100644
index 000000000000..c971ff982bfa
--- /dev/null
+++ b/kde-base/smokekde/smokekde-4.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokekde/smokekde-4.8.0.ebuild,v 1.1 2012/01/25 18:17:10 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - KDE bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep smokeqt)
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ kate? ( $(add_kdebase_dep kate) )
+ okular? ( $(add_kdebase_dep okular) )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}