summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:46:34 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:46:34 +0000
commite5021892cbab99d63673acc54a33ea262bc7f4cf (patch)
treef9fba61f69427167c82c010561aa9665b889210c /kde-base/smoke
parent[kde-base] Drop KDE SC 4.4.1 (diff)
downloadgentoo-2-e5021892cbab99d63673acc54a33ea262bc7f4cf.tar.gz
gentoo-2-e5021892cbab99d63673acc54a33ea262bc7f4cf.tar.bz2
gentoo-2-e5021892cbab99d63673acc54a33ea262bc7f4cf.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.4.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 7e5a53623a65..693ebc785ecf 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.98 2010/03/31 23:32:57 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.99 2010/05/03 21:46:34 alexxy Exp $
+
+*smoke-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +smoke-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -smoke-4.4.0.ebuild:
Remove old KDE versions.
diff --git a/kde-base/smoke/smoke-4.4.3.ebuild b/kde-base/smoke/smoke-4.4.3.ebuild
new file mode 100644
index 000000000000..8ac75b98f2cd
--- /dev/null
+++ b/kde-base/smoke/smoke-4.4.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.3.ebuild,v 1.1 2010/05/03 21:46:34 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="akonadi kdevplatform okular +phonon qimageblitz qtmultimedia qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ kdevplatform? ( dev-util/kdevplatform:4 )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=kde-base/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_SMOKE)
+ $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
+ $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_enable qtmultimedia QTMULTIMEDIA_SMOKE)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ )
+ kde4-meta_src_configure
+}