summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 19:45:37 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 19:45:37 +0000
commitc5ab62119a6e330842a4d27cd99c57b26e46a208 (patch)
tree180f0705ad667b0f773254bef5be764b86b51098 /kde-base/smoke
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-c5ab62119a6e330842a4d27cd99c57b26e46a208.tar.gz
gentoo-2-c5ab62119a6e330842a4d27cd99c57b26e46a208.tar.bz2
gentoo-2-c5ab62119a6e330842a4d27cd99c57b26e46a208.zip
Version bump KDE 4.4.1
(Portage version: 2.2_rc63/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.4.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 09e7e5e41bac..a91cdbfbdf79 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.94 2010/03/02 10:27:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.95 2010/03/02 19:45:37 tampakrap Exp $
+
+*smoke-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org> +smoke-4.4.1.ebuild:
+ Version bump
02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> -smoke-4.3.3.ebuild,
-smoke-4.3.4.ebuild, -smoke-4.3.5.ebuild:
diff --git a/kde-base/smoke/smoke-4.4.1.ebuild b/kde-base/smoke/smoke-4.4.1.ebuild
new file mode 100644
index 000000000000..846339e1765d
--- /dev/null
+++ b/kde-base/smoke/smoke-4.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.1.ebuild,v 1.1 2010/03/02 19:45:37 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="akonadi kdevplatform okular +phonon qimageblitz qtmultimedia qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ kdevplatform? ( dev-util/kdevplatform:4 )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=kde-base/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_SMOKE)
+ $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
+ $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_enable qtmultimedia QTMULTIMEDIA_SMOKE)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ )
+ kde4-meta_src_configure
+}