summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commitb2b19c584143aa3164437f01988775b3baced7a1 (patch)
treed682b95b673d238fe82f54a47550663464f4e5cd /kde-base/smoke
parentSort test dep. Remove useless dies. (diff)
downloadgentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.gz
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.bz2
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.zip
Version bump
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.6.4.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 94df2a898df4..c9346d0384af 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.137 2011/06/10 11:50:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.138 2011/06/10 18:00:07 dilfridge Exp $
+
+*smoke-4.6.4 (10 Jun 2011)
+
+ 10 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> +smoke-4.6.4.ebuild:
+ Version bump
10 Jun 2011; Markos Chandras <hwoarang@gentoo.org> smoke-4.6.3.ebuild:
Stable on amd64 wrt bug #369979
diff --git a/kde-base/smoke/smoke-4.6.4.ebuild b/kde-base/smoke/smoke-4.6.4.ebuild
new file mode 100644
index 000000000000..3118b7031939
--- /dev/null
+++ b/kde-base/smoke/smoke-4.6.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.6.4.ebuild,v 1.1 2011/06/10 18:00:07 dilfridge Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdebindings"
+ kde_eclass="kde4-meta"
+fi
+
+inherit ${kde_eclass}
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="akonadi attica debug kate okular +phonon qimageblitz qscintilla qwt semantic-desktop webkit"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ kate? ( $(add_kdebase_dep kate) )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+KMSAVELIBS=1
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ ${kde_eclass}_src_configure
+}