summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 23:59:43 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 23:59:43 +0000
commit3c0c42ac1cb677c41fc0d699132ceb63f4e2c661 (patch)
tree82ef688dd446dd042f2f0f8ee872d068242ff0ba /kde-base/smoke
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-3c0c42ac1cb677c41fc0d699132ceb63f4e2c661.tar.gz
gentoo-2-3c0c42ac1cb677c41fc0d699132ceb63f4e2c661.tar.bz2
gentoo-2-3c0c42ac1cb677c41fc0d699132ceb63f4e2c661.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/files/digest-smoke-3.5.83
-rw-r--r--kde-base/smoke/smoke-3.5.8.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 4baa2c0b296c..bfb846b5bcc3 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.48 2007/08/11 17:30:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.49 2007/10/19 23:59:42 philantrop Exp $
+
+*smoke-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org> +smoke-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> smoke-3.5.6.ebuild:
x86 stable wrt #176297
diff --git a/kde-base/smoke/files/digest-smoke-3.5.8 b/kde-base/smoke/files/digest-smoke-3.5.8
new file mode 100644
index 000000000000..4968662d1c8f
--- /dev/null
+++ b/kde-base/smoke/files/digest-smoke-3.5.8
@@ -0,0 +1,3 @@
+MD5 b5980331e09c34dcea64297046746cc3 kdebindings-3.5.8.tar.bz2 3492800
+RMD160 dfab98ca8d9c30344ef2732f03deea87d15a9c74 kdebindings-3.5.8.tar.bz2 3492800
+SHA256 39b8449aaf0bee81a701b0915c4d742149ef37450483cce3133c6163ea3a732c kdebindings-3.5.8.tar.bz2 3492800
diff --git a/kde-base/smoke/smoke-3.5.8.ebuild b/kde-base/smoke/smoke-3.5.8.ebuild
new file mode 100644
index 000000000000..7e01a5823765
--- /dev/null
+++ b/kde-base/smoke/smoke-3.5.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-3.5.8.ebuild,v 1.1 2007/10/19 23:59:42 philantrop Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="kalyptus/"
+KM_MAKEFILESREV=1
+MAXKDEVER=${PV}
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine: a language-agnostic bindings generator for qt and kde"
+HOMEPAGE="http://developer.kde.org/language-bindings/smoke/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lang/perl
+ dev-python/qscintilla" # QScintilla is an optional dep, there's a configure flag for it, but I don't want
+ # to introduce a local noqscintilla use flag as it's a light dep.
+ # Of course it'd be nice if someone told me what the difference is between a smoke
+ # compiled with and without qscintilla support. --danarmak
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# enable-final works, but requires at least 1.5GB of RAM to complete without swapping,
+# so it's best to turn it off here. (I don't have that much RAM, so can't estimate
+# how much would be enough, but it's at least that much... --danarmak)
+src_compile() {
+ # Remove this to avoid strange errors
+ rm -f "${S}/kalyptus/configure.in"
+
+ kde-meta_src_compile myconf
+ # override myconf's setting of enable-final
+ myconf="$myconf --disable-final"
+
+ # Needs patch to fix paralell building again
+ MAKEOPTS="$MAKEOPTS -j1"
+
+ kde-meta_src_compile configure make
+}