summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit9105207da0f7d5c2674846f47a99baf903903d3b (patch)
treed50899ea0ccfdaee04b35bfc24e0bc89b3d4c12a /kde-base/qyoto
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadgentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.gz
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.bz2
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.zip
[kde-base] KDE SC 4.7.2
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.7.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 2a86a69aed1e..4c046c02cbfd 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.2 2011/09/07 20:13:43 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.3 2011/10/06 18:10:51 alexxy Exp $
+
+*qyoto-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*qyoto-4.7.1 (07 Sep 2011)
diff --git a/kde-base/qyoto/qyoto-4.7.2.ebuild b/kde-base/qyoto/qyoto-4.7.2.ebuild
new file mode 100644
index 000000000000..dc66a4498de8
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.7.2.ebuild,v 1.1 2011/10/06 18:10:51 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}