summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38 (patch)
tree101b1b44b57d9ee9df5ea837005a27beae915f3d /kde-base/qyoto
parentAdd support for Prefix. bug #407193 (diff)
downloadgentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.gz
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.bz2
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.zip
Version bump KDE SC 4.8.1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.8.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 47302acbf496..5ecf76534d28 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.16 2012/02/18 16:25:17 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.17 2012/03/06 23:35:05 dilfridge Exp $
+
+*qyoto-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> +qyoto-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
18 Feb 2012; nixnut <nixnut@gentoo.org> qyoto-4.7.4.ebuild:
ppc stable #396359
diff --git a/kde-base/qyoto/qyoto-4.8.1.ebuild b/kde-base/qyoto/qyoto-4.8.1.ebuild
new file mode 100644
index 000000000000..1c96eadd1a36
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.8.1.ebuild,v 1.1 2012/03/06 23:35:05 dilfridge Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}