summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:17:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:17:00 +0000
commitf470d31a4abaadd8a4f15c7cd03778dcd9dd394f (patch)
treef28a8c9a7cdde1ba25634372514c74acaab80de2 /kde-base/quanta
parentneed eutils #149919 by Andreas Niederl (diff)
downloadgentoo-2-f470d31a4abaadd8a4f15c7cd03778dcd9dd394f.tar.gz
gentoo-2-f470d31a4abaadd8a4f15c7cd03778dcd9dd394f.tar.bz2
gentoo-2-f470d31a4abaadd8a4f15c7cd03778dcd9dd394f.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/quanta')
-rw-r--r--kde-base/quanta/ChangeLog7
-rw-r--r--kde-base/quanta/files/digest-quanta-3.5.53
-rw-r--r--kde-base/quanta/quanta-3.5.5.ebuild29
3 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/quanta/ChangeLog b/kde-base/quanta/ChangeLog
index 6ea37e49bd8d..3f613c8d72a2 100644
--- a/kde-base/quanta/ChangeLog
+++ b/kde-base/quanta/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/quanta
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.55 2006/09/23 20:16:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.56 2006/10/03 13:17:00 flameeyes Exp $
+
+*quanta-3.5.5 (03 Oct 2006)
+
+ 03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +quanta-3.5.5.ebuild:
+ Bump to 3.5.5 (pre-release).
23 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> quanta-3.5.2.ebuild,
quanta-3.5.3.ebuild, quanta-3.5.4.ebuild:
diff --git a/kde-base/quanta/files/digest-quanta-3.5.5 b/kde-base/quanta/files/digest-quanta-3.5.5
new file mode 100644
index 000000000000..40601c205441
--- /dev/null
+++ b/kde-base/quanta/files/digest-quanta-3.5.5
@@ -0,0 +1,3 @@
+MD5 d0655fd0286607f4726a82db96f00da3 kdewebdev-3.5.5.tar.bz2 6046994
+RMD160 b74f1171558f60715ed823a18e101790fe9e19c1 kdewebdev-3.5.5.tar.bz2 6046994
+SHA256 3dcb8be41a1499532ef3e60fd292638e147b91882bf3d9cf48b83ed0b8bc36b3 kdewebdev-3.5.5.tar.bz2 6046994
diff --git a/kde-base/quanta/quanta-3.5.5.ebuild b/kde-base/quanta/quanta-3.5.5.ebuild
new file mode 100644
index 000000000000..9c220955b0c3
--- /dev/null
+++ b/kde-base/quanta/quanta-3.5.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.5.5.ebuild,v 1.1 2006/10/03 13:17:00 flameeyes Exp $
+KMNAME=kdewebdev
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc tidy"
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${RDEPEND}
+$(deprange $PV $MAXKDEVER kde-base/kfilereplace)
+$(deprange $PV $MAXKDEVER kde-base/kimagemapeditor)
+$(deprange $PV $MAXKDEVER kde-base/klinkstatus)
+$(deprange $PV $MAXKDEVER kde-base/kommander)
+$(deprange $PV $MAXKDEVER kde-base/kxsldbg)
+tidy? ( app-text/htmltidy )
+doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+ kde-meta_src_compile
+}