summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commitb5c71598bd396d68feb09813aad0c75a45f81a3a (patch)
treeb738e19f08caad8c28f1ee6bee7051613495e2de /kde-base/qtruby
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadgentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.gz
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.bz2
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.zip
Version bump KDE SC 4.11.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog7
-rw-r--r--kde-base/qtruby/qtruby-4.11.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index d10ffcdb6b97..24ee59db73a6 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.175 2013/09/03 19:50:30 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.176 2013/10/09 23:04:18 creffett Exp $
+
+*qtruby-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +qtruby-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
03 Sep 2013; Chris Reffett <creffett@gentoo.org> -qtruby-4.11.0.ebuild:
Drop KDE 4.11.0
diff --git a/kde-base/qtruby/qtruby-4.11.2.ebuild b/kde-base/qtruby/qtruby-4.11.2.ebuild
new file mode 100644
index 000000000000..1457b41f03ba
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.11.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.11.2.ebuild,v 1.1 2013/10/09 23:04:18 creffett Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}