summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-02-14 12:23:37 +0000
committerJohannes Huber <johu@gentoo.org>2014-02-14 12:23:37 +0000
commita1ab0dda77cd21794340644644d2cffbb0f11a90 (patch)
tree03bff3dee805ff642b4469af426536e9d7377297 /kde-base/qtruby
parentBump to 1.0.1, thanks to Nikoli (diff)
downloadgentoo-2-a1ab0dda77cd21794340644644d2cffbb0f11a90.tar.gz
gentoo-2-a1ab0dda77cd21794340644644d2cffbb0f11a90.tar.bz2
gentoo-2-a1ab0dda77cd21794340644644d2cffbb0f11a90.zip
Remove KDE SC 4.12.1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.12.1.ebuild71
2 files changed, 4 insertions, 72 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index c46bf37f28b3..c6f34032f7e9 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.194 2014/02/09 10:05:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.195 2014/02/14 12:23:05 johu Exp $
+
+ 14 Feb 2014; Johannes Huber <johu@gentoo.org> -qtruby-4.12.1.ebuild:
+ Remove KDE SC 4.12.1
09 Feb 2014; Agostino Sarubbo <ago@gentoo.org> qtruby-4.11.5.ebuild:
Stable for amd64, wrt bug #493782
diff --git a/kde-base/qtruby/qtruby-4.12.1.ebuild b/kde-base/qtruby/qtruby-4.12.1.ebuild
deleted file mode 100644
index 9209e3931c2f..000000000000
--- a/kde-base/qtruby/qtruby-4.12.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.12.1.ebuild,v 1.1 2014/01/18 11:23:47 dilfridge Exp $
-
-EAPI=5
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-USE_RUBY="ruby19"
-# Only one ruby version is supported:
-# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}