summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-06-19 13:02:04 +0000
committerChris Reffett <creffett@gentoo.org>2014-06-19 13:02:04 +0000
commit5d86256036a8f6f2c145b5596a796f355c15052f (patch)
treeb5c0569884c2bfeec9387ba0209ff104d2a05750 /kde-base/qtruby
parent[QA] Respect LDFLAGS wrt bug 335364, credit to Cyprien Nicolas <gentoo-bugzie... (diff)
downloadgentoo-2-5d86256036a8f6f2c145b5596a796f355c15052f.tar.gz
gentoo-2-5d86256036a8f6f2c145b5596a796f355c15052f.tar.bz2
gentoo-2-5d86256036a8f6f2c145b5596a796f355c15052f.zip
Remove KDE SC 4.13.0
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 28DB029C)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.13.0.ebuild71
2 files changed, 4 insertions, 72 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 17735be5e553..b97980f1f399 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.214 2014/06/15 16:56:18 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.215 2014/06/19 13:02:01 creffett Exp $
+
+ 19 Jun 2014; Chris Reffett <creffett@gentoo.org> -qtruby-4.13.0.ebuild:
+ Remove KDE SC 4.13.0
*qtruby-4.13.2 (15 Jun 2014)
diff --git a/kde-base/qtruby/qtruby-4.13.0.ebuild b/kde-base/qtruby/qtruby-4.13.0.ebuild
deleted file mode 100644
index 3c9511b8962c..000000000000
--- a/kde-base/qtruby/qtruby-4.13.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.13.0.ebuild,v 1.2 2014/04/17 00:43:01 johu Exp $
-
-EAPI=5
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-USE_RUBY="ruby19"
-# Only one ruby version is supported:
-# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}