summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-11-13 20:21:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-11-13 20:21:30 +0000
commit32382dc86f8823bcda5bdd758624f60c2fb8c0d5 (patch)
treef40084028e5a35f758897da863ef069bd3cf06ea /kde-base/qtruby
parentStable for HPPA (bug #438804). (diff)
downloadgentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.tar.gz
gentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.tar.bz2
gentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.zip
Remove KDE SC 4.9.2
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.9.2.ebuild74
2 files changed, 4 insertions, 75 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 952b11db376b..4e5381a8b78f 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.126 2012/11/13 20:04:14 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.127 2012/11/13 20:21:05 johu Exp $
+
+ 13 Nov 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.9.2.ebuild:
+ Remove KDE SC 4.9.2
13 Nov 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.9.1.ebuild:
Remove KDE SC 4.9.1
diff --git a/kde-base/qtruby/qtruby-4.9.2.ebuild b/kde-base/qtruby/qtruby-4.9.2.ebuild
deleted file mode 100644
index 244de7f3df12..000000000000
--- a/kde-base/qtruby/qtruby-4.9.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.9.2.ebuild,v 1.1 2012/10/02 18:11:53 johu Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}