summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-05 20:26:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-05 20:26:35 +0000
commita51ef7bbccf3ee9fddba2b4b74ba19f41821afc4 (patch)
tree96353df60aadd05f8b9c79933a14796e72ad9a4b /kde-base/pykde4
parentVersion bump (diff)
downloadgentoo-2-a51ef7bbccf3ee9fddba2b4b74ba19f41821afc4.tar.gz
gentoo-2-a51ef7bbccf3ee9fddba2b4b74ba19f41821afc4.tar.bz2
gentoo-2-a51ef7bbccf3ee9fddba2b4b74ba19f41821afc4.zip
Revbump to fix building with PyQt4-4.9.5. Bug #436578
(Portage version: 2.1.11.23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-4.9.2-pyqt45.patch54
-rw-r--r--kde-base/pykde4/pykde4-4.9.2-r1.ebuild161
3 files changed, 222 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index da2e88cbd1ba..09c83d3396c9 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.178 2012/10/02 18:12:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.179 2012/10/05 20:26:35 hwoarang Exp $
+
+*pykde4-4.9.2-r1 (05 Oct 2012)
+
+ 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/pykde4-4.9.2-pyqt45.patch, +pykde4-4.9.2-r1.ebuild:
+ Revbump to fix building with PyQt4-4.9.5. Bug #436578
*pykde4-4.9.2 (02 Oct 2012)
diff --git a/kde-base/pykde4/files/pykde4-4.9.2-pyqt45.patch b/kde-base/pykde4/files/pykde4-4.9.2-pyqt45.patch
new file mode 100644
index 000000000000..9fcced59fcb4
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.9.2-pyqt45.patch
@@ -0,0 +1,54 @@
+Index: pykde4-4.9.2/CMakeLists.txt
+===================================================================
+--- pykde4-4.9.2.orig/CMakeLists.txt
++++ pykde4-4.9.2/CMakeLists.txt
+@@ -33,7 +33,7 @@ INCLUDE(SIPMacros)
+
+ FIND_PACKAGE(PyQt4 REQUIRED)
+ IF(PYQT4_VERSION STRLESS "040900") # These version numbers also appear in ../CMakeLists.txt
+- MESSAGE(FATAL_ERROR "The version of PyQt found is too old. 4.9 or later is required.")
++ MESSAGE(FATAL_ERROR "The version of PyQt found is too old. 4.9.5 or later is required.")
+ ENDIF(PYQT4_VERSION STRLESS "040900")
+
+
+@@ -95,9 +95,19 @@ SET(SIP_DISABLE_FEATURES VendorID PyQt_N
+
+ # Use an extra option when compiling on Python 3.
+ IF (PYTHON_3)
+- SET(SIP_EXTRA_OPTIONS -g -x Py_v3)
++ IF(PYQT4_VERSION STRGREATER "040904")
++ #Disable for newer PyQt
++ SET(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector -x Py_v3)
++ ELSE(PYQT4_VERSION STRGREATER "040904")
++ SET(SIP_EXTRA_OPTIONS -g -x Py_v3)
++ ENDIF(PYQT4_VERSION STRGREATER "040904")
+ ELSE (PYTHON_3)
+- SET(SIP_EXTRA_OPTIONS -g)
++ IF(PYQT4_VERSION STRGREATER "040904")
++ #Disable for newer PyQt
++ SET(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector)
++ ELSE(PYQT4_VERSION STRGREATER "040904")
++ SET(SIP_EXTRA_OPTIONS -g -x Py_v3)
++ ENDIF(PYQT4_VERSION STRGREATER "040904")
+ ENDIF (PYTHON_3)
+
+ ADD_DEFINITIONS(-D_REENTRANT -DQT_CORE_LIB -DQT_GUI_LIB -DUSING_SOPRANO_NRLMODEL_UNSTABLE_API)
+Index: pykde4-4.9.2/sip/kdecore/typedefs.sip
+===================================================================
+--- pykde4-4.9.2.orig/sip/kdecore/typedefs.sip
++++ pykde4-4.9.2/sip/kdecore/typedefs.sip
+@@ -951,6 +951,9 @@ template <TYPE1>
+ %End
+ };
+
++%Feature PyKDE_QVector
++
++%If(PyKDE_QVector)
+ %MappedType QVector<int>
+ {
+ %TypeHeaderCode
+@@ -1025,3 +1028,4 @@ template <TYPE1>
+ return sipGetState(sipTransferObj);
+ %End
+ };
++%End
diff --git a/kde-base/pykde4/pykde4-4.9.2-r1.ebuild b/kde-base/pykde4/pykde4-4.9.2-r1.ebuild
new file mode 100644
index 000000000000..8cad5458b81d
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.9.2-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.9.2-r1.ebuild,v 1.1 2012/10/05 20:26:35 hwoarang Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*:2.5"
+RESTRICT_PYTHON_ABIS="*-jython 2.4 2.7-pypy-*"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+
+OPENGL_REQUIRED="always"
+inherit python portability kde4-base multilib
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples semantic-desktop"
+REQUIRED_USE="test? ( semantic-desktop )"
+
+# blocker added due to compatibility issues and error during compile time
+RDEPEND="
+ >=dev-python/sip-4.14
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop=')
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ >=dev-libs/soprano-2.8.0
+ )
+ aqua? ( >=dev-python/PyQt4-4.9.5[dbus,declarative,sql,svg,webkit,aqua] )
+ !aqua? ( >=dev-python/PyQt4-4.9.5[dbus,declarative,sql,svg,webkit,X] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pyqt45.patch
+)
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-base_pkg_setup
+
+ have_python2=false
+
+ scan_python_versions() {
+ [[ ${PYTHON_ABI} == 2.* ]] && have_python2=true
+ :
+ }
+ python_execute_function -q scan_python_versions
+ if ! ${have_python2}; then
+ ewarn "You do not have a Python 2 version selected."
+ ewarn "kpythonpluginfactory will not be built"
+ fi
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
+
+ sed -i -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' kpythonpluginfactory/CMakeLists.txt
+
+ if ${have_python2}; then
+ mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
+ cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r1" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
+ fi
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DWITH_PolkitQt=OFF
+ -DWITH_QScintilla=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ -DPYTHON_EXECUTABLE=$(PYTHON -a)
+ )
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_configure
+ }
+
+ python_execute_function configuration
+}
+
+echo_and_run() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ compilation() {
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ kde4-base_src_compile
+ }
+ python_execute_function compilation
+
+ if ${have_python2}; then
+ cd "${WORKDIR}/wrapper"
+ echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
+ -shared \
+ ${CFLAGS} ${CPPFLAGS} \
+ -DEPREFIX="\"${EPREFIX}\"" \
+ -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
+ -o kpythonpluginfactorywrapper.lo \
+ kpythonpluginfactorywrapper.c
+ echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
+ -shared -module -avoid-version \
+ ${CFLAGS} ${LDFLAGS} \
+ -o kpythonpluginfactory.la \
+ -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
+ kpythonpluginfactorywrapper.lo \
+ $(dlopen_lib)
+ fi
+}
+
+src_install() {
+ installation() {
+ cd "${S}_build-${PYTHON_ABI}"
+ emake DESTDIR="${T}/images/${PYTHON_ABI}" install
+ }
+ python_execute_function installation
+
+ python_merge_intermediate_installation_images "${T}/images"
+
+ # As we don't call the eclass's src_install, we have to install the docs manually
+ DOCS=("${S}"/{AUTHORS,NEWS,README})
+ use doc && HTML_DOCS=("${S}/docs/html/")
+ base_src_install_docs
+
+ if ${have_python2}; then
+ cd "${WORKDIR}/wrapper"
+ echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ fi
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ python_mod_optimize PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EPREFIX}/usr/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-base_pkg_postrm
+
+ python_mod_cleanup PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
+}