summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3 (patch)
treeacda1b1644e123ebe3d9623addcce4017adb629d /kde-base/phonon-kde
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadgentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.gz
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.bz2
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.zip
Version bump KDE SC 4.9.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.9.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index b2ac026372e5..c9ae6d20cbf2 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.125 2012/06/21 21:54:46 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.126 2012/08/01 22:17:35 johu Exp $
+
+*phonon-kde-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +phonon-kde-4.9.0.ebuild:
+ Version bump KDE SC 4.9.0
*phonon-kde-4.8.4 (21 Jun 2012)
diff --git a/kde-base/phonon-kde/phonon-kde-4.9.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.9.0.ebuild
new file mode 100644
index 000000000000..1d152b9bd960
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.9.0.ebuild,v 1.1 2012/08/01 22:17:35 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}