summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
commitdaec5bb32d717672af35168b16bb8164f2533810 (patch)
tree64932fcb885be528a75e27b8edcfefe4903e17a0 /kde-base/perlqt
parentSwitch 9999 to truly live 'develop' branch per user request. (diff)
downloadgentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.gz
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.bz2
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.zip
Bump KDE SC 4.10.1
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7887F787)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.10.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index d70491a405c8..de0db7bebd63 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.64 2013/03/03 02:33:15 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.65 2013/03/06 13:42:10 dilfridge Exp $
+
+*perlqt-4.10.1 (06 Mar 2013)
+
+ 06 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org> +perlqt-4.10.1.ebuild:
+ Version bump KDE SC 4.10.1
03 Mar 2013; Davide Pesavento <pesa@gentoo.org> metadata.xml:
Adjust metadata for Qt category move.
diff --git a/kde-base/perlqt/perlqt-4.10.1.ebuild b/kde-base/perlqt/perlqt-4.10.1.ebuild
new file mode 100644
index 000000000000..a10a535c9c7e
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.10.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.10.1.ebuild,v 1.1 2013/03/06 13:42:10 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}