summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
commitd7e1a4366ff9ba481421bd6f31539139be38e99a (patch)
tree06cf6fc3ad2522bd965c90e770efaf564b4caf81 /kde-base/perlqt
parentMask KDE SC 4.10.0 for keywording bug #455960 (diff)
downloadgentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.gz
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.bz2
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.zip
Add KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.10.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index a34af8277b65..97d8d12c2906 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.61 2013/01/28 12:13:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.62 2013/02/07 04:57:51 alexxy Exp $
+
+*perlqt-4.10.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> +perlqt-4.10.0.ebuild:
+ Version bump KDE SC 4.10.0
28 Jan 2013; Agostino Sarubbo <ago@gentoo.org> -perlqt-4.9.3.ebuild,
-perlqt-4.9.4.ebuild:
diff --git a/kde-base/perlqt/perlqt-4.10.0.ebuild b/kde-base/perlqt/perlqt-4.10.0.ebuild
new file mode 100644
index 000000000000..5d977e0933aa
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.10.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.10.0.ebuild,v 1.1 2013/02/07 04:57:51 alexxy Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}