summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
commitb19b0ead03dc10cdaa9aea4001d560c962a1f597 (patch)
treef22852d83a670996da46e118f610a0f6dfa2f4ba /kde-base/perlqt
parentsys-kernel/aufs-sources: Fix problem due to renamed tmpfs patch, #513332 (diff)
downloadgentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.gz
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.bz2
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.zip
Version bump KDE SC 4.13.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog8
-rw-r--r--kde-base/perlqt/perlqt-4.13.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index b3d3a75143d1..a58bd06c6236 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.144 2014/05/13 17:43:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.145 2014/06/15 16:56:45 kensington Exp $
+
+*perlqt-4.13.2 (15 Jun 2014)
+
+ 15 Jun 2014; Michael Palimaka <kensington@gentoo.org> +perlqt-4.13.2.ebuild,
+ files/perlqt-4.10.80-vendor.patch:
+ Version bump KDE SC 4.13.2
*perlqt-4.13.1 (13 May 2014)
diff --git a/kde-base/perlqt/perlqt-4.13.2.ebuild b/kde-base/perlqt/perlqt-4.13.2.ebuild
new file mode 100644
index 000000000000..44d068d67811
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.13.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.13.2.ebuild,v 1.1 2014/06/15 16:56:45 kensington Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.80-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${BUILD_DIR}/blib/arch:${BUILD_DIR}/blib/lib" kde4-base_src_test
+}