summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38 (patch)
tree101b1b44b57d9ee9df5ea837005a27beae915f3d /kde-base/oxygen-icons
parentAdd support for Prefix. bug #407193 (diff)
downloadgentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.gz
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.bz2
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.zip
Version bump KDE SC 4.8.1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/oxygen-icons')
-rw-r--r--kde-base/oxygen-icons/ChangeLog8
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.8.1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/oxygen-icons/ChangeLog b/kde-base/oxygen-icons/ChangeLog
index 2ceed67f4059..cd67299cb849 100644
--- a/kde-base/oxygen-icons/ChangeLog
+++ b/kde-base/oxygen-icons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/oxygen-icons
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/ChangeLog,v 1.94 2012/02/21 12:52:35 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/ChangeLog,v 1.95 2012/03/06 23:35:24 dilfridge Exp $
+
+*oxygen-icons-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +oxygen-icons-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
20 Feb 2012; Johannes Huber <johu@gentoo.org> -oxygen-icons-4.6.3-r1.ebuild:
Remove KDE SC 4.6.3
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.8.1.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.8.1.ebuild
new file mode 100644
index 000000000000..732b64615b53
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/oxygen-icons-4.8.1.ebuild,v 1.1 2012/03/06 23:35:24 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+else
+ # Upstream does not ship releases properly so we dont want all versions
+ MY_PV="4.8.1"
+ MY_P="${PN}-${MY_PV}"
+fi
+KDE_REQUIRED="never"
+inherit kde4-base
+
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+# Note that the upstream tarball is .bz2, ours is .xz -- if upstream
+# changes its compression format to .xz, we will need to change the
+# filename of one of the tarballs
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~alexxy/distfiles/${MY_P}.tar.xz )
+ bindist? ( ${SRC_URI//${PV}/${MY_PV}} )
+"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == *9999 ]] || S=${WORKDIR}/${MY_P}