summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit34c78a7dee48cc1df1e35264ea7e2c682926f487 (patch)
treef8ccbed0c1c5eda4ad6795fb2d3a688f91bb62e1 /kde-base/okular
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadgentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.gz
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.bz2
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.zip
KDE 4.8.4 version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.8.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 38d14b15226e..1a216c1d73ad 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.141 2012/06/16 16:44:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.142 2012/06/21 21:55:04 dilfridge Exp $
+
+*okular-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org> +okular-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
16 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> okular-4.7.4.ebuild,
okular-4.8.3.ebuild, metadata.xml:
diff --git a/kde-base/okular/okular-4.8.4.ebuild b/kde-base/okular/okular-4.8.4.ebuild
new file mode 100644
index 000000000000..3a69a653a3b1
--- /dev/null
+++ b/kde-base/okular/okular-4.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.8.4.ebuild,v 1.1 2012/06/21 21:55:04 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.12.3-r3[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}