summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild')
-rw-r--r--kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild b/kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild
new file mode 100644
index 000000000000..3adc18ed54d6
--- /dev/null
+++ b/kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/mplayerthumbs/mplayerthumbs-4.6.1.ebuild,v 1.1 2011/03/04 17:59:55 alexxy Exp $
+
+EAPI=3
+
+KMNAME="kdemultimedia"
+inherit kde4-meta
+
+DESCRIPTION="A Thumbnail Generator for Video Files on KDE filemanagers."
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=41180"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug mplayer"
+
+RDEPEND="
+ !media-video/mplayerthumbs
+ || (
+ $(add_kdebase_dep dolphin)
+ $(add_kdebase_dep konqueror)
+ )
+ mplayer? ( media-video/mplayer )
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_PHONON_SUPPORT=ON
+ )
+
+ kde4-meta_src_configure
+}