summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-28 20:02:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-28 20:02:13 +0000
commitaefe31253f34223c5c3a1ae5a239ae1bd9437700 (patch)
treef115087b93e4599100d1b12ea186b1b44ab695a1 /kde-base/marble
parentVersion bump (diff)
downloadgentoo-2-aefe31253f34223c5c3a1ae5a239ae1bd9437700.tar.gz
gentoo-2-aefe31253f34223c5c3a1ae5a239ae1bd9437700.tar.bz2
gentoo-2-aefe31253f34223c5c3a1ae5a239ae1bd9437700.zip
[kde-base/marble] Fix bug #367571
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/marble')
-rw-r--r--kde-base/marble/ChangeLog6
-rw-r--r--kde-base/marble/files/marble-4.5.5-gpsd.patch43
-rw-r--r--kde-base/marble/marble-4.7.0.ebuild7
3 files changed, 53 insertions, 3 deletions
diff --git a/kde-base/marble/ChangeLog b/kde-base/marble/ChangeLog
index 33b7c8d80127..b9a3e7d2840b 100644
--- a/kde-base/marble/ChangeLog
+++ b/kde-base/marble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/marble
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/ChangeLog,v 1.101 2011/07/27 14:04:48 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/ChangeLog,v 1.102 2011/07/28 20:02:13 alexxy Exp $
+
+ 28 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/marble-4.5.5-gpsd.patch, marble-4.7.0.ebuild:
+ Fix bug #367571
*marble-4.7.0 (27 Jul 2011)
diff --git a/kde-base/marble/files/marble-4.5.5-gpsd.patch b/kde-base/marble/files/marble-4.5.5-gpsd.patch
new file mode 100644
index 000000000000..ec515e99d88e
--- /dev/null
+++ b/kde-base/marble/files/marble-4.5.5-gpsd.patch
@@ -0,0 +1,43 @@
+Index: kdeedu-4.5.5/marble/src/plugins/positionprovider/gpsd/GpsdConnection.cpp
+===================================================================
+--- kdeedu-4.5.5.orig/marble/src/plugins/positionprovider/gpsd/GpsdConnection.cpp
++++ kdeedu-4.5.5/marble/src/plugins/positionprovider/gpsd/GpsdConnection.cpp
+@@ -18,6 +18,9 @@ using namespace Marble;
+
+ GpsdConnection::GpsdConnection( QObject* parent )
+ : QObject( parent ),
++#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 5 )
++ m_gpsd("localhost", DEFAULT_GPSD_PORT),
++#endif
+ m_timer( 0 )
+ {
+ connect( &m_timer, SIGNAL( timeout() ), this, SLOT( update() ) );
+@@ -26,7 +29,11 @@ GpsdConnection::GpsdConnection( QObject*
+ void GpsdConnection::initialize()
+ {
+ m_timer.stop();
++#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 5 )
++ gps_data_t* data;
++#else
+ gps_data_t* data = m_gpsd.open();
++#endif
+ if ( data ) {
+ m_status = PositionProviderStatusAcquiring;
+ emit statusChanged( m_status );
+@@ -73,8 +80,16 @@ void GpsdConnection::initialize()
+ void GpsdConnection::update()
+ {
+ #if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 3 ) && defined( PACKET_SET )
++#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 5 )
++ if ( m_gpsd.waiting(0) ) {
++#else
+ if ( m_gpsd.waiting() ) {
++#endif
++#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 5 )
++ gps_data_t* data = m_gpsd.read();
++#else
+ gps_data_t* data = m_gpsd.poll();
++#endif
+ if ( data && data->set & PACKET_SET ) {
+ emit gpsdInfo( *data );
+ }
diff --git a/kde-base/marble/marble-4.7.0.ebuild b/kde-base/marble/marble-4.7.0.ebuild
index fd43545e6a11..ed27093c08d8 100644
--- a/kde-base/marble/marble-4.7.0.ebuild
+++ b/kde-base/marble/marble-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.7.0.ebuild,v 1.1 2011/07/27 14:04:48 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.7.0.ebuild,v 1.2 2011/07/28 20:02:13 alexxy Exp $
EAPI=3
@@ -28,7 +28,10 @@ RDEPEND="${DEPEND}
!sci-geosciences/marble
"
-PATCHES=( "${FILESDIR}/${PN}-4.7-magic.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7-magic.patch"
+ "${FILESDIR}/${PN}-4.5.5-gpsd.patch"
+ )
# note that this patch will not work if we ever make a qt-only build
pkg_setup() {