summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:31:44 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:31:44 +0000
commit2d9cd16c5307199971be860fe9c0909f53d8c0ad (patch)
tree825156202366f646a97b4061411e4bcee86f33f7 /kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-2d9cd16c5307199971be860fe9c0909f53d8c0ad.tar.gz
gentoo-2-2d9cd16c5307199971be860fe9c0909f53d8c0ad.tar.bz2
gentoo-2-2d9cd16c5307199971be860fe9c0909f53d8c0ad.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild')
-rw-r--r--kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild b/kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild
new file mode 100644
index 000000000000..a2670d9ce4d1
--- /dev/null
+++ b/kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/libkpimexchange-3.5.9.ebuild,v 1.1 2008/02/20 23:31:44 philantrop Exp $
+
+KMNAME=kdepim
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE PIM exchange library"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=kde-base/libkcal-${PV}:${SLOT}"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcal libkcal"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/"
+
+src_compile() {
+ kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd "${S}/libkcal/libical/src/libical" && make ical.h
+ # generate "icalss.h"
+ cd "${S}/libkcal/libical/src/libicalss" && make icalss.h
+
+ kde-meta_src_compile make
+}