summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3 (patch)
treeacda1b1644e123ebe3d9623addcce4017adb629d /kde-base/libkcddb
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadgentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.gz
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.bz2
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.zip
Version bump KDE SC 4.9.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/libkcddb')
-rw-r--r--kde-base/libkcddb/ChangeLog7
-rw-r--r--kde-base/libkcddb/libkcddb-4.9.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/libkcddb/ChangeLog b/kde-base/libkcddb/ChangeLog
index bc95ce70dff8..f712202a56f3 100644
--- a/kde-base/libkcddb/ChangeLog
+++ b/kde-base/libkcddb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/libkcddb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/ChangeLog,v 1.212 2012/06/21 21:55:07 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/ChangeLog,v 1.213 2012/08/01 22:17:35 johu Exp $
+
+*libkcddb-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +libkcddb-4.9.0.ebuild:
+ Version bump KDE SC 4.9.0
*libkcddb-4.8.4 (21 Jun 2012)
diff --git a/kde-base/libkcddb/libkcddb-4.9.0.ebuild b/kde-base/libkcddb/libkcddb-4.9.0.ebuild
new file mode 100644
index 000000000000..d7c1af5c62b1
--- /dev/null
+++ b/kde-base/libkcddb/libkcddb-4.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/libkcddb-4.9.0.ebuild,v 1.1 2012/08/01 22:17:35 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:3 )
+"
+RDEPEND="${DEPEND}"
+add_blocker kscd "<4.8.50"
+add_blocker kdemultimedia-kioslaves
+
+KMSAVELIBS="true"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz3)
+ )
+
+ kde4-base_src_configure
+}