summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
commitb31cc0441f4628bad93065beae2d74cb436c08c6 (patch)
treeb946ea6b122ad7c1de4b8c58dc400606f74fb540 /kde-base/kwin
parentdev-libs/uriparser: 0.7.7 (diff)
downloadgentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.gz
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.bz2
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.zip
Version bump KDE SC 4.8.2
(Portage version: 2.2.0_alpha98/cvs/Linux i686)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.8.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index a9b2b23757ee..48913ecfa654 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.269 2012/04/04 19:03:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.270 2012/04/04 23:59:14 johu Exp $
+
+*kwin-4.8.2 (04 Apr 2012)
+
+ 04 Apr 2012; Johannes Huber <johu@gentoo.org> +kwin-4.8.2.ebuild:
+ Version bump KDE SC 4.8.2
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> kwin-4.8.1.ebuild:
Stable for amd64, wrt bug #409403
diff --git a/kde-base/kwin/kwin-4.8.2.ebuild b/kde-base/kwin/kwin-4.8.2.ebuild
new file mode 100644
index 000000000000..16f327e002bc
--- /dev/null
+++ b/kde-base/kwin/kwin-4.8.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.8.2.ebuild,v 1.1 2012/04/04 23:59:14 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles opengl xinerama"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs opengl)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? (
+ || ( ( >=media-libs/mesa-7.10[egl(+),gles] <media-libs/mesa-7.12[egl(+),gles] )
+ >=media-libs/mesa-7.12[egl(+),gles2] )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+)
+
+# you need one of these
+REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ -DWITH_X11_Xcomposite=ON
+ )
+
+ kde4-meta_src_configure
+}