summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 17:59:16 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 17:59:16 +0000
commit703642a32e0bab2a4df612e43ab857365bad7871 (patch)
tree0ee4d6887f1d52733da186b8f0c181efab32615e /kde-base/kttsd
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-703642a32e0bab2a4df612e43ab857365bad7871.tar.gz
gentoo-2-703642a32e0bab2a4df612e43ab857365bad7871.tar.bz2
gentoo-2-703642a32e0bab2a4df612e43ab857365bad7871.zip
Bump shiny new KDE 4.2.0
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog7
-rw-r--r--kde-base/kttsd/kttsd-4.2.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index 045582e6cf59..c8c4781cd469 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.106 2009/01/14 15:43:51 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.107 2009/01/27 17:59:16 alexxy Exp $
+
+*kttsd-4.2.0 (27 Jan 2009)
+
+ 27 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +kttsd-4.2.0.ebuild:
+ Bump KDE-4.2.0
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> -kttsd-4.1.2.ebuild,
-kttsd-4.1.3.ebuild:
diff --git a/kde-base/kttsd/kttsd-4.2.0.ebuild b/kde-base/kttsd/kttsd-4.2.0.ebuild
new file mode 100644
index 000000000000..7435615d46ee
--- /dev/null
+++ b/kde-base/kttsd/kttsd-4.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-4.2.0.ebuild,v 1.1 2009/01/27 17:59:16 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeaccessibility"
+inherit kde4-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug htmlhandbook +ktts +phonon"
+
+DEPEND="
+ >=kde-base/kcmshell-${PV}:${SLOT}
+ >=kde-base/knotify-${PV}:${SLOT}
+ ktts? (
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ phonon? ( >=media-sound/phonon-4.3.0 )
+ )
+"
+
+RDEPEND="${DEPEND}
+ ktts? (
+ app-accessibility/epos
+ app-accessibility/festival
+ app-accessibility/flite
+ app-accessibility/freetts
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with alsa Alsa)
+ -DKDE4_KTTSD_PHONON=$(use phonon && echo OFF || echo ON)
+ -DKDE4_KTTSD_ALSA=$(use alsa && echo ON || echo OFF)
+ $(cmake-utils_use_with ktts Kttsmodule)"
+
+ kde4-meta_src_configure
+}