summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
commite022af9e09a506be3fa71a44a9dacb94554ae3b0 (patch)
tree927f368d76846ba1fc8372e4a16b73202107d984 /kde-base/ksystemlog
parentfixing testing (diff)
downloadgentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.gz
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.bz2
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.zip
Version bump KDE SC 4.12.5
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.12.5.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 07a95cf596aa..341e6caa7915 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.201 2014/04/17 00:43:10 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.202 2014/04/29 18:34:43 johu Exp $
+
+*ksystemlog-4.12.5 (29 Apr 2014)
+
+ 29 Apr 2014; Johannes Huber <johu@gentoo.org> +ksystemlog-4.12.5.ebuild:
+ Version bump KDE SC 4.12.5
16 Apr 2014; Johannes Huber <johu@gentoo.org> ksystemlog-4.13.0.ebuild:
Restore KEYWORDS for KDE SC 4.13.0
diff --git a/kde-base/ksystemlog/ksystemlog-4.12.5.ebuild b/kde-base/ksystemlog/ksystemlog-4.12.5.ebuild
new file mode 100644
index 000000000000..b1a53ea63f27
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.12.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.12.5.ebuild,v 1.1 2014/04/29 18:34:43 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}