summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 10:11:55 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-02 10:11:55 +0000
commitff6bb74f96b166f0f50f23a90342355b60d13d5f (patch)
treebcca146166bd220fde610cb85fb572c22f3dadc0 /kde-base/ksysguard
parentAdd kde-4.1.2 into the tree from the kde-testing overlay. (diff)
downloadgentoo-2-ff6bb74f96b166f0f50f23a90342355b60d13d5f.tar.gz
gentoo-2-ff6bb74f96b166f0f50f23a90342355b60d13d5f.tar.bz2
gentoo-2-ff6bb74f96b166f0f50f23a90342355b60d13d5f.zip
Add kde-4.1.2 into the tree from the kde-testing overlay.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog8
-rw-r--r--kde-base/ksysguard/ksysguard-4.1.2.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 0d397fd855d7..a6358cb30d80 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.113 2008/09/13 23:59:54 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.114 2008/10/02 10:11:55 jmbsvicetto Exp $
+
+*ksysguard-4.1.2 (02 Oct 2008)
+
+ 02 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +ksysguard-4.1.2.ebuild:
+ Add kde-4.1.2 into the tree from the kde-testing overlay.
*ksysguard-3.5.10 (13 Sep 2008)
diff --git a/kde-base/ksysguard/ksysguard-4.1.2.ebuild b/kde-base/ksysguard/ksysguard-4.1.2.ebuild
new file mode 100644
index 000000000000..6427091296b5
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.1.2.ebuild,v 1.1 2008/10/02 10:11:55 jmbsvicetto Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook lm_sensors"
+
+COMMONDEPEND="
+ >=kde-base/kdebase-data-${PV}:${SLOT}
+ >=kde-base/libplasma-${PV}:${SLOT}
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto"
+RDEPEND="${COMMONDEPEND}
+ >=kde-base/plasma-workspace-${PV}:${SLOT}"
+
+KMEXTRA="libs/ksysguard/"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with lm_sensors Sensors)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # one out of two tests are broken. we just disable it. last tested on 4.1.0.
+ sed -e '/guitest/s/^/#DONOTTEST/' \
+ -i "${S}"/libs/ksysguard/tests/CMakeLists.txt
+
+ kde4-meta_src_test
+}