summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
commitf8633b9ab4fbc263024fc7d9e4b25610366de9c2 (patch)
tree6a1fa56dffbbac34e8c5f2f3a57fbdac07646b6c /kde-base/kstars
parentAlways download/symlink unifont, bug 522956. (diff)
downloadgentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.gz
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.bz2
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.zip
Version bump KDE SC 4.14.1
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.14.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 9c76369799b5..dc7d20ffa412 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.337 2014/08/20 16:02:50 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.338 2014/09/16 18:17:31 johu Exp $
+
+*kstars-4.14.1 (16 Sep 2014)
+
+ 16 Sep 2014; Johannes Huber <johu@gentoo.org> +kstars-4.14.1.ebuild:
+ Version bump KDE SC 4.14.1
*kstars-4.14.0 (20 Aug 2014)
diff --git a/kde-base/kstars/kstars-4.14.1.ebuild b/kde-base/kstars/kstars-4.14.1.ebuild
new file mode 100644
index 000000000000..c1a64b2269b7
--- /dev/null
+++ b/kde-base/kstars/kstars-4.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.14.1.ebuild,v 1.1 2014/09/16 18:17:31 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDE Desktop Planetarium"
+HOMEPAGE="http://www.kde.org/applications/education/kstars http://edu.kde.org/kstars"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+REQUIRED_USE="indi? ( fits )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ $(add_kdebase_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.9.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-base_src_configure
+}