summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/ksquares/ksquares-4.6.5.ebuild
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksquares/ksquares-4.6.5.ebuild')
-rw-r--r--kde-base/ksquares/ksquares-4.6.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/ksquares/ksquares-4.6.5.ebuild b/kde-base/ksquares/ksquares-4.6.5.ebuild
new file mode 100644
index 000000000000..c963b44808fa
--- /dev/null
+++ b/kde-base/ksquares/ksquares-4.6.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksquares/ksquares-4.6.5.ebuild,v 1.1 2011/07/09 15:13:58 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdegames"
+inherit games-ggz kde4-meta
+
+DESCRIPTION="KSquares is an implementation of the game squares for KDE4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+src_prepare() {
+ # cmake is doing this really weird
+ sed -i \
+ -e "s:register_ggz_module:#register_ggz_module:g" \
+ ${PN}/src/CMakeLists.txt || die "ggz removal failed"
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ kde4-meta_src_install
+ # and also we have to prepare the ggz dir
+ insinto "${GGZ_MODDIR}"
+ newins ${PN}/src/module.dsc ${P}.dsc
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ games-ggz_pkg_postinst
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+ games-ggz_pkg_postrm
+}