summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/ksplash
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.11.11.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 8a91f5612a3f..f48bb8becb2a 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.224 2014/06/15 17:24:01 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.225 2014/07/16 17:40:12 johu Exp $
+
+*ksplash-4.11.11 (16 Jul 2014)
+
+ 16 Jul 2014; Johannes Huber <johu@gentoo.org> +ksplash-4.11.11.ebuild:
+ Version bump KDE Workspace 4.11.11
*ksplash-4.11.10 (15 Jun 2014)
diff --git a/kde-base/ksplash/ksplash-4.11.11.ebuild b/kde-base/ksplash/ksplash-4.11.11.ebuild
new file mode 100644
index 000000000000..ed4c426ed32f
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.11.11.ebuild,v 1.1 2014/07/16 17:40:12 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}