summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 18:42:56 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 18:42:56 +0000
commit8470bddf9f9e6d0290007a0ccc336de83c39269f (patch)
tree84e508e1c671210643b050b30a3822627bf86140 /kde-base/ksplash
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-8470bddf9f9e6d0290007a0ccc336de83c39269f.tar.gz
gentoo-2-8470bddf9f9e6d0290007a0ccc336de83c39269f.tar.bz2
gentoo-2-8470bddf9f9e6d0290007a0ccc336de83c39269f.zip
Version bump KDE 4.4.1
(Portage version: 2.2_rc63/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.4.1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 927f38abd23c..9cb6128b8125 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.56 2010/02/20 11:34:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.57 2010/03/02 18:42:56 tampakrap Exp $
+
+*ksplash-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +ksplash-4.4.1.ebuild:
+ Version bump
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> ksplash-4.3.5.ebuild:
amd64/x86 stable wrt #300393
diff --git a/kde-base/ksplash/ksplash-4.4.1.ebuild b/kde-base/ksplash/ksplash-4.4.1.ebuild
new file mode 100644
index 000000000000..bf0b55789262
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.4.1.ebuild,v 1.1 2010/03/02 18:42:56 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}