summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 22:50:38 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 22:50:38 +0000
commit53843088c34de8469290d1de4853a8386f8363b7 (patch)
tree70084686b2db0d7390592c905cc3115055ce325b /kde-base/ksplash
parentmerkaartor: add missing dep to qt-svg (diff)
downloadgentoo-2-53843088c34de8469290d1de4853a8386f8363b7.tar.gz
gentoo-2-53843088c34de8469290d1de4853a8386f8363b7.tar.bz2
gentoo-2-53843088c34de8469290d1de4853a8386f8363b7.zip
Bump kde to 4.1.4
(Portage version: 2.2_rc21/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog9
-rw-r--r--kde-base/ksplash/ksplash-4.1.4.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 6e2446bd3bb3..85ca840e2aa0 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.14 2008/11/16 08:03:18 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.15 2009/01/13 22:50:38 alexxy Exp $
+
+*ksplash-4.1.4 (13 Jan 2009)
+
+ 13 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +ksplash-4.1.4.ebuild:
+ Bump to 4.1.4
15 Nov 2008; Mike Frysinger <vapier@gentoo.org> ksplash-4.1.3.ebuild:
Add ppc/ppc64 love #244306.
diff --git a/kde-base/ksplash/ksplash-4.1.4.ebuild b/kde-base/ksplash/ksplash-4.1.4.ebuild
new file mode 100644
index 000000000000..b62edd5ce800
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.1.4.ebuild,v 1.1 2009/01/13 22:50:38 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}