summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/ksnapshot
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksnapshot')
-rw-r--r--kde-base/ksnapshot/ChangeLog7
-rw-r--r--kde-base/ksnapshot/ksnapshot-4.6.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/ksnapshot/ChangeLog b/kde-base/ksnapshot/ChangeLog
index c59907d3caea..0a2b8dfd9693 100644
--- a/kde-base/ksnapshot/ChangeLog
+++ b/kde-base/ksnapshot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksnapshot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ChangeLog,v 1.177 2011/07/06 20:05:26 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ChangeLog,v 1.178 2011/07/09 15:14:05 alexxy Exp $
+
+*ksnapshot-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksnapshot-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-ksnapshot-4.6.2-r1.ebuild:
diff --git a/kde-base/ksnapshot/ksnapshot-4.6.5.ebuild b/kde-base/ksnapshot/ksnapshot-4.6.5.ebuild
new file mode 100644
index 000000000000..bcae91d5bf31
--- /dev/null
+++ b/kde-base/ksnapshot/ksnapshot-4.6.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksnapshot/ksnapshot-4.6.5.ebuild,v 1.1 2011/07/09 15:14:05 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdegraphics"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE Screenshot Utility"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug kipi"
+
+DEPEND="
+ kipi? ( $(add_kdebase_dep libkipi) )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.6.2-kipi.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with kipi)
+ )
+
+ ${kde_eclass}_src_configure
+}
+
+if [[ ${PV} != *9999 ]]; then
+src_install() {
+ kde4-meta_src_install
+
+ # why, oh why?!
+ rm "${ED}/usr/share/apps/cmake/modules/FindKSane.cmake" || die
+}
+fi