summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-23 00:56:47 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-23 00:56:47 +0000
commit40ff28b4f8c906bd75d53535755e796b914a7434 (patch)
treecd1157f67ff59c50a3b265b9eb95edfe9faf14cd /kde-base/korundum
parentVersion bump. (diff)
downloadgentoo-2-40ff28b4f8c906bd75d53535755e796b914a7434.tar.gz
gentoo-2-40ff28b4f8c906bd75d53535755e796b914a7434.tar.bz2
gentoo-2-40ff28b4f8c906bd75d53535755e796b914a7434.zip
Version bump.
(Portage version: 2.1.2.7)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog7
-rw-r--r--kde-base/korundum/files/digest-korundum-3.5.73
-rw-r--r--kde-base/korundum/korundum-3.5.7.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 08323114c631..1a0f9c13be36 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.57 2007/02/05 12:11:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.58 2007/05/23 00:56:47 carlo Exp $
+
+*korundum-3.5.7 (23 May 2007)
+
+ 23 May 2007; Carsten Lohrke <carlo@gentoo.org> +korundum-3.5.7.ebuild:
+ Version bump.
05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
-files/korundum-3.5.4-more.patch, -files/qtruby-3.5.4-more.patch:
diff --git a/kde-base/korundum/files/digest-korundum-3.5.7 b/kde-base/korundum/files/digest-korundum-3.5.7
new file mode 100644
index 000000000000..05bcfa5cf6e3
--- /dev/null
+++ b/kde-base/korundum/files/digest-korundum-3.5.7
@@ -0,0 +1,3 @@
+MD5 bc8a95f0cfd52ad0559a775cf045f230 kdebindings-3.5.7.tar.bz2 5577725
+RMD160 847907a204fe02e3a99a9d51a719d203d8831099 kdebindings-3.5.7.tar.bz2 5577725
+SHA256 a453e3097231c3ec278f50009bfd348dea9d818a41ac6e3940b234e46f596043 kdebindings-3.5.7.tar.bz2 5577725
diff --git a/kde-base/korundum/korundum-3.5.7.ebuild b/kde-base/korundum/korundum-3.5.7.ebuild
new file mode 100644
index 000000000000..09e0c154f873
--- /dev/null
+++ b/kde-base/korundum/korundum-3.5.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-3.5.7.ebuild,v 1.1 2007/05/23 00:56:47 carlo Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt libsmokekde smoke/kde"
+KMCOMPILEONLY="qtruby"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE ruby bindings"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/qtruby-$PV ~kde-base/smoke-3.3.1"
+DEPEND=" >=virtual/ruby-1.8
+$(deprange $PV $MAXKDEVER kde-base/qtruby)
+$(deprange 3.5.6 $MAXKDEVER kde-base/smoke)"
+RDEPEND="${DEPEND}"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke and qtruby versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+