summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-09 10:30:06 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-09 10:30:06 +0000
commite4e974a66645cb9dd27890344439fd0b9827db09 (patch)
tree4b8b383a6bb1a8f95d8e8366ed6390b314a3a935 /kde-base/kmail
parentStable on alpha/ia64/sparc (bug #418707) (diff)
downloadgentoo-2-e4e974a66645cb9dd27890344439fd0b9827db09.tar.gz
gentoo-2-e4e974a66645cb9dd27890344439fd0b9827db09.tar.bz2
gentoo-2-e4e974a66645cb9dd27890344439fd0b9827db09.zip
Add upstream patch to fix build with gcc44 wrt bug #429742.
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog6
-rw-r--r--kde-base/kmail/files/kmail-4.9.0-gcc44.patch21
-rw-r--r--kde-base/kmail/kmail-4.9.0-r1.ebuild4
-rw-r--r--kde-base/kmail/kmail-4.9.0.ebuild85
4 files changed, 29 insertions, 87 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 3cd2d7df1f15..38cc63485cee 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.298 2012/08/07 11:04:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.299 2012/08/09 10:30:06 johu Exp $
+
+ 09 Aug 2012; Johannes Huber <johu@gentoo.org> +files/kmail-4.9.0-gcc44.patch,
+ -kmail-4.9.0.ebuild, kmail-4.9.0-r1.ebuild:
+ Add upstream patch to fix build with gcc44 wrt bug #429742.
*kmail-4.8.5 (07 Aug 2012)
diff --git a/kde-base/kmail/files/kmail-4.9.0-gcc44.patch b/kde-base/kmail/files/kmail-4.9.0-gcc44.patch
new file mode 100644
index 000000000000..29e7115e1960
--- /dev/null
+++ b/kde-base/kmail/files/kmail-4.9.0-gcc44.patch
@@ -0,0 +1,21 @@
+commit 92bface95453799620cd2368a7c0771c4304bbf3
+Author: David Faure <faure@kde.org>
+Date: Thu Aug 9 11:58:30 2012 +0200
+
+ Fix compilation with gcc-4.4.7, a gentoo user reported this fixed the issue.
+
+ (Message::Foo was ambiguous due to KMime::Message and namespace Message in
+ messagecomposer/util.h)
+
+diff --git a/kmail/kmreaderwin.cpp b/kmail/kmreaderwin.cpp
+index 92593f2..c4bcd86 100644
+--- a/kmail/kmreaderwin.cpp
++++ b/kmail/kmreaderwin.cpp
+@@ -45,7 +45,6 @@ using MessageViewer::CSSHelper;
+ #include "stringutil.h"
+
+ #include <kmime/kmime_mdn.h>
+-using namespace KMime;
+
+ #include "messageviewer/viewer.h"
+ using namespace MessageViewer;
diff --git a/kde-base/kmail/kmail-4.9.0-r1.ebuild b/kde-base/kmail/kmail-4.9.0-r1.ebuild
index fd6c44773783..ed7c36d4b7a8 100644
--- a/kde-base/kmail/kmail-4.9.0-r1.ebuild
+++ b/kde-base/kmail/kmail-4.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.9.0-r1.ebuild,v 1.1 2012/08/04 00:09:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.9.0-r1.ebuild,v 1.2 2012/08/09 10:30:06 johu Exp $
EAPI=4
@@ -60,6 +60,8 @@ KMEXTRA="
KMLOADLIBS="kdepim-common-libs"
+PATCHES=( "${FILESDIR}/${P}-gcc44.patch" )
+
src_configure() {
# Bug 308903
use ppc64 && append-flags -mminimal-toc
diff --git a/kde-base/kmail/kmail-4.9.0.ebuild b/kde-base/kmail/kmail-4.9.0.ebuild
deleted file mode 100644
index 48d163ff78aa..000000000000
--- a/kde-base/kmail/kmail-4.9.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.9.0.ebuild,v 1.1 2012/08/01 22:17:35 johu Exp $
-
-EAPI=4
-
-KDE_HANDBOOK="optional"
-KMNAME="kdepim"
-KDE_SCM="git"
-VIRTUALX_REQUIRED=test
-inherit flag-o-matic kde4-meta
-
-DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug"
-
-DEPEND="
- $(add_kdebase_dep kdepimlibs 'semantic-desktop')
- $(add_kdebase_dep korganizer)
- $(add_kdebase_dep kdepim-common-libs)
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-# bug 393147
-
-KMEXTRACTONLY="
- akonadi_next/
- archivemailagent/
- calendarsupport/
- korganizer/
- kresources/
- libkleo/
- libkpgp/
- libkdepimdbusinterfaces/
- kdgantt2/
-"
-KMCOMPILEONLY="
- messagecomposer/
- messagecore/
- messagelist/
- messageviewer/
- templateparser/
- incidenceeditor-ng/
- calendarsupport/
-"
-KMEXTRA="
- kmailcvt/
- ksendemail/
- libksieve/
- mailcommon/
- mailfilteragent/
- mailimporter/
- ontologies/
- plugins/messageviewer/
-"
-
-KMLOADLIBS="kdepim-common-libs"
-
-src_configure() {
- # Bug 308903
- use ppc64 && append-flags -mminimal-toc
-
- kde4-meta_src_configure
-}
-
-src_compile() {
- kde4-meta_src_compile kmail_xml
- kde4-meta_src_compile
-}
-
-pkg_postinst() {
- kde4-meta_pkg_postinst
-
- if ! has_version kde-base/kdepim-kresources:${SLOT}; then
- echo
- elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
- echo
- fi
- if ! has_version kde-base/kleopatra:${SLOT}; then
- echo
- elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
- echo
- fi
-}